cPanel解决无法安装php5.2.7

做国外生意的朋友换购一台服务器,需要重新安装cPanel,花了几十美元买来的cPanel不支持5.2.17,最低版本支持到5.3.27,最高5.5,这让人非常恼火,上官网找解决方法,如下为安装php5.2.17的方法。

1. 准备cpanel专供php

# cd /var/cpanel/easy/apache/custom_opt_mods
# wget http://docs.cpanel.net/twiki/pub/EasyApache/EasyApacheCustomModules/custom_opt_mod-PHP5217.tar.gz
# tar -xzvf custom_opt_mod-PHP5217.tar.gz

2. 通过easyApache重装

搜索easyApache,然后一步步看图。

cPanel

easyApache

cPanel

cPanel安装php5.2.17

cPanel

cPanel安装php5.2.17

cPanel

cPanel安装php5.2.17

cPanel

cPanel安装php5.2.17

 

然后和往常一样一步步往下走即可完成。

3. php扩展配置

因为这不是cPanel原生的安装,所以没有php的扩展选项,它会根据php压缩包内的默认配置参数安装。如果你需要支持额外选项,例如gd和ftp,如下操作:

 

一行一个,它会解析成–with-gd –enable-ftp,然后整合到configure后面。

备注:安装模块的方法我没有实际测试,因为默认安装以及满足了朋友的要求,cPanel安装速度很慢,所以我不在测试了。