NGINX增加加载动态模块

NGINX 1.9.11开始增加加载动态模块支持,从此不再需要替换nginx文件即可增加第三方扩展。目前官方只有几个模块支持动态加载,第三方模块需要升级支持才可编译成模块。

如上可看出官方支持5个动态模块编译,需要增加第三方模块,使用参数–add-dynamic-module=即可。

NGINX动态模块语法

load_module

Default: —

配置段: main

说明:版本必须>=1.9.11

实例: